Uso ECMAScript 2015

1. Compatibilidad

ECMAScript 2015 anteriormente llamado ECMAScript 6, está disponible con todos los navegadores recientes: Chrome, Firefox, Edge, Safari, Opera. Por otro lado, no está disponible en Internet Explorer (antepasado de Edge), pero la penetración en el mercado de este navegador, está disminuyendo de manera constante a menos del 2 % en la actualidad. También se tiene muy en cuenta en el móvil. ECMAScript 6

Por lo tanto, ahora es posible utilizar ECMAScript 2015 en sitios web para el gran público en general. Para seguir siendo compatible con los navegadores antiguos, es posible configurar una librería de JavaScript con menos funciones, sin obstaculizar el funcionamiento del sitio web. Para hacer esto, se probará la versión del navegador tan pronto como se cargue la página. Posteriormente se tendrá en cuenta la librería correcta según el resultado.

La primera librería ofrecerá un servicio mínimo para que el sitio funcione con Internet Explorer.

// jib.js 
document.body.onload = function() { alert( "Versión simple" ); }; 

La segunda librería ofrecerá el servicio completo para todos los navegadores compatibles 2015.

// lib2015.js 
document.body.onload = function() { alert( "Versión óptima" ); }; 

Solo resta detectar el navegador actual con ayuda de la propiedad window.navigator.userAgent y cargar el script correcto...

Si desea saber más, le proponemos el siguiente libro:
couv_EIT3JAV.png
60-signet.svg
Versión impresa
20-ecran_lettre.svg
Versión online
41-logo_abonnement.svg
En ilimitado con la suscripción ENI
130-boutique.svg
En la tienda oficial de ENI
Anterior
Espacio de nombres
Siguiente
Estructura de datos más eficaz